Вниз
Скачать: CL | DM;

Ошибка при Post   Найти похожие ветки 

 
Василиск   (2003-10-28 11:52) [0]

Есть TADOQuery c запросом select * from ... where type_id = :type_id
заначение параметра определено, датасет открыт.
делаю Insert, вставляю значения полей, делаю Post - получаю
"Произошли ошибки во время выполнения многошаговой операции. Проверьте значения всех состояний". Причем запись ложится в БД.
В чем трабл?
(В TADOQuery определены пара lookup полей)


 
Delirium ©   (2003-10-28 13:03) [1]

Пишешь NULL туда, где это запрещено


 
Василиск   (2003-10-28 13:24) [2]

Обычно на это по другому ругаются :) В моем случае оказалось, что ругается клиент.
Причину я нашел, но объяснить не могу.
В этой таблице есть поле типа datetime default getdate(), в клиентском гриде есть столбец, где fieldname это самое поле. Убираю этот столбец из грида, все нормально работает, добавляю - получаю глюк.
В чем дело не пойму.


 
bushmen ©   (2003-10-28 13:34) [3]

>В этой таблице есть поле типа datetime default getdate(), в >клиентском гриде есть столбец, где fieldname это самое поле. >Убираю этот столбец из грида, все нормально работает, добавляю ->получаю глюк.

Формат дат разный - написано же: date time


 
Василиск   (2003-10-28 13:48) [4]

Где это он разный? в гриде и серверной таблице? :)

getDate совершенно спокойно вставляет в datetime


 
bushmen ©   (2003-10-28 14:50) [5]

>Василиск

А у тебя никогда не возникало мысли, что существует несколько форматов представления даты?



Страницы: 1 вся ветка

Скачать: CL | DM;



Память: 0.46 MB
Время: 0.017 c
1-56661
Jack
2003-11-05 10:46
2003.11.17
Exception


7-56936
DeadMeat
2003-09-05 18:47
2003.11.17
Значок в SystemTray


1-56648
_незнайка_
2003-11-05 12:12
2003.11.17
В чем проблема?


1-56658
Sectey
2003-11-05 10:24
2003.11.17
Компонент в рунтайме


14-56833
Dean
2003-10-28 06:21
2003.11.17
Меня заманали юзеры




   Наверх