Форум: "Базы";
Поиск по всему сайту: delphimaster.net;
Текущий архив: 2002.02.28;
Скачать: [xml.tar.bz2];




Вниз

Вопросик про фильтры(+) 


DenK_vrtz   (2002-02-01 11:01) [0]

Всем привет!!!
Нарвался я тут на такую проблему и никак не врублюсь от чего это происходит.
У меня таблица имеет поле типа NUMBER(7,2). Так вот. Если значение поля имеет значение с одним десятичным знаком, то данные фильтруются, если с двумя, то нет, т.е. ничего не отфильтровывается. У товарища по работе с этой таблицей такая же проблема, но наоборот. С одним знаком не фильтрует, а с двумя фильтрует. В чем может быть глюк? Помогите!!!

P.S. Переводить число в строку - решает проблему, но это не хорошо!!!



Sergey13   (2002-02-01 11:40) [1]

А через чего работаешь? BDE,DOA или еще чего. Навскидку проблема, наверное, в каких то настройках на клиенте (в сессии)- типа количество дробных знаков в цифровом поле. Конкретнее - надо копать.

PS: а если попробовать поле сделать просто NUMBER?



DenK_vrtz   (2002-02-01 12:17) [2]

Работаю через BDE. Чего больше понять не могу, так на некоторых таблицах вообще проблем не сеществует, 1,2,3 хоть 10 знаков после запятой, фильтрует без вопросов. А тут ну никак не отфильтровывает и не только у меня. Кстати, делал пробную таблицу с полем просто NUMBER - один фиг, такой же глюк!!!




Форум: "Базы";
Поиск по всему сайту: delphimaster.net;
Текущий архив: 2002.02.28;
Скачать: [xml.tar.bz2];




Наверх





Память: 0.72 MB
Время: 0.024 c
1-90608           Геральт               2002-02-12 18:56  2002.02.28  
Справка по RxLib


3-90529           dimich                2002-02-05 18:32  2002.02.28  
Помогите с ADO


14-90670          skiph                 2002-01-12 11:33  2002.02.28  
unix


1-90596           Стас                  2002-02-12 14:14  2002.02.28  
Перехват сообщений


3-90497           HiFiBear              2002-02-01 10:28  2002.02.28  
Проьлема с библиотеками ado