Форум: "Базы";
Поиск по всему сайту: delphimaster.net;
Текущий архив: 2002.02.14;
Скачать: [xml.tar.bz2];




Вниз

беда с BDE 


labert   (2002-01-15 18:51) [0]

Пожалуйста, помогите разобраться в чем дело:

На MSSQL сервере лежит база.
На локальной машине стоят Дельфи + BDE. Алиас настроен. SQL Explorer все видит, Enterprise manager тоже.

Программа делает запрос, запрос проходит нормально, но выдает пустой набор.

Тот же запрос в Enterprise Manager проходит совершенно нормально. (Результат не пустой.)
В SQL Explorer запрос проходит, только если не запущен Дельфи с этой самой прогой.
Если Дельфи запущен, то SQL Explorer выдает BDE Error $000F
(хотя все таблицы просмариваются через вкладку data)

Причем самое интересное в том, что exe-шник этой проги не работает и на другом компе, на котором алиас гарантированно нормальный.



MetallAdm   (2002-01-17 12:18) [1]

А вы пробовали ставить Query.Active:=True; ?!!!



Romul   (2002-01-18 11:54) [2]

Приведи код. И где у тебя пустой набор появляется, в DBGrid?



Alan   (2002-01-18 19:07) [3]

Приведи код, а также укажи используемые компоненты.




Форум: "Базы";
Поиск по всему сайту: delphimaster.net;
Текущий архив: 2002.02.14;
Скачать: [xml.tar.bz2];




Наверх





Память: 0.71 MB
Время: 0.012 c
1-42740           Dmitriy_R             2002-01-30 13:18  2002.02.14  
Создание лог файлов


14-42847          Snake2000             2001-12-24 12:22  2002.02.14  
... а при нем задача...


3-42688           Ars P                 2002-01-22 13:04  2002.02.14  
Создаю алиас в SQL Explorer-е для базы interbase, расположенной на сервере...


3-42697           @andrew               2002-01-22 15:30  2002.02.14  
ПРИВЕТ ВСЕМ!!! Помоготе построить запрос:


1-42715           blankalex             2002-02-01 12:14  2002.02.14  
Raize Components