Форум: "Базы";
Поиск по всему сайту: delphimaster.net;
Текущий архив: 2002.02.14;
Скачать: [xml.tar.bz2];




Вниз

беда с BDE 


labert   (2002-01-15 18:51) [0]

Пожалуйста, помогите разобраться в чем дело:

На MSSQL сервере лежит база.
На локальной машине стоят Дельфи + BDE. Алиас настроен. SQL Explorer все видит, Enterprise manager тоже.

Программа делает запрос, запрос проходит нормально, но выдает пустой набор.

Тот же запрос в Enterprise Manager проходит совершенно нормально. (Результат не пустой.)
В SQL Explorer запрос проходит, только если не запущен Дельфи с этой самой прогой.
Если Дельфи запущен, то SQL Explorer выдает BDE Error $000F
(хотя все таблицы просмариваются через вкладку data)

Причем самое интересное в том, что exe-шник этой проги не работает и на другом компе, на котором алиас гарантированно нормальный.



MetallAdm   (2002-01-17 12:18) [1]

А вы пробовали ставить Query.Active:=True; ?!!!



Romul   (2002-01-18 11:54) [2]

Приведи код. И где у тебя пустой набор появляется, в DBGrid?



Alan   (2002-01-18 19:07) [3]

Приведи код, а также укажи используемые компоненты.




Форум: "Базы";
Поиск по всему сайту: delphimaster.net;
Текущий архив: 2002.02.14;
Скачать: [xml.tar.bz2];




Наверх





Память: 0.71 MB
Время: 0.013 c
1-42762           _SnAke_               2002-01-31 11:57  2002.02.14  
Отображение главной формы


3-42658           Eraser                2002-01-21 10:04  2002.02.14  
Скоко можно записей в DB


6-42815           eblade                2001-11-23 11:49  2002.02.14  
Connection: Keep-Alive и TClientSocket


6-42820           sergio_b              2001-11-26 02:10  2002.02.14  
Использование UDP - Запрос сервера Half-Life


14-42870          BWG                   2001-12-24 14:47  2002.02.14  
Требуется написать терминалку