Форум: "Базы";
Поиск по всему сайту: delphimaster.net;
Текущий архив: 2002.02.14;
Скачать: [xml.tar.bz2];




Вниз

беда с BDE 


labert   (2002-01-15 18:51) [0]

Пожалуйста, помогите разобраться в чем дело:

На MSSQL сервере лежит база.
На локальной машине стоят Дельфи + BDE. Алиас настроен. SQL Explorer все видит, Enterprise manager тоже.

Программа делает запрос, запрос проходит нормально, но выдает пустой набор.

Тот же запрос в Enterprise Manager проходит совершенно нормально. (Результат не пустой.)
В SQL Explorer запрос проходит, только если не запущен Дельфи с этой самой прогой.
Если Дельфи запущен, то SQL Explorer выдает BDE Error $000F
(хотя все таблицы просмариваются через вкладку data)

Причем самое интересное в том, что exe-шник этой проги не работает и на другом компе, на котором алиас гарантированно нормальный.



MetallAdm   (2002-01-17 12:18) [1]

А вы пробовали ставить Query.Active:=True; ?!!!



Romul   (2002-01-18 11:54) [2]

Приведи код. И где у тебя пустой набор появляется, в DBGrid?



Alan   (2002-01-18 19:07) [3]

Приведи код, а также укажи используемые компоненты.




Форум: "Базы";
Поиск по всему сайту: delphimaster.net;
Текущий архив: 2002.02.14;
Скачать: [xml.tar.bz2];




Наверх





Память: 0.72 MB
Время: 0.023 c
6-42813           vinni2000             2001-11-23 11:52  2002.02.14  
Как соеденить клиента и сервера


3-42661           Net_DAN               2002-01-21 10:57  2002.02.14  
Не выгружается серверная часть


1-42795           Tomvitas              2002-01-30 23:47  2002.02.14  
Как в TStringGrid програмно перенести Selection с одной строки в другую?


4-42891           XM-AD                 2001-12-13 09:16  2002.02.14  
Мастаки!!!!!! HELP.PLZ!!!!


1-42768           Vitek                 2002-01-31 13:06  2002.02.14  
Текстовые компоненты