Форум: "Базы";
Поиск по всему сайту: delphimaster.net;
Текущий архив: 2002.02.14;
Скачать: [xml.tar.bz2];




Вниз

беда с BDE 


labert   (2002-01-15 18:51) [0]

Пожалуйста, помогите разобраться в чем дело:

На MSSQL сервере лежит база.
На локальной машине стоят Дельфи + BDE. Алиас настроен. SQL Explorer все видит, Enterprise manager тоже.

Программа делает запрос, запрос проходит нормально, но выдает пустой набор.

Тот же запрос в Enterprise Manager проходит совершенно нормально. (Результат не пустой.)
В SQL Explorer запрос проходит, только если не запущен Дельфи с этой самой прогой.
Если Дельфи запущен, то SQL Explorer выдает BDE Error $000F
(хотя все таблицы просмариваются через вкладку data)

Причем самое интересное в том, что exe-шник этой проги не работает и на другом компе, на котором алиас гарантированно нормальный.



MetallAdm   (2002-01-17 12:18) [1]

А вы пробовали ставить Query.Active:=True; ?!!!



Romul   (2002-01-18 11:54) [2]

Приведи код. И где у тебя пустой набор появляется, в DBGrid?



Alan   (2002-01-18 19:07) [3]

Приведи код, а также укажи используемые компоненты.




Форум: "Базы";
Поиск по всему сайту: delphimaster.net;
Текущий архив: 2002.02.14;
Скачать: [xml.tar.bz2];




Наверх





Память: 0.72 MB
Время: 0.015 c
1-42770           HDD                   2002-01-30 05:54  2002.02.14  
Помогите пожалуйста!


6-42817           Kirill45              2001-11-25 02:55  2002.02.14  
Net


1-42742           asdf                  2002-01-30 13:24  2002.02.14  
Создание объектов


1-42762           _SnAke_               2002-01-31 11:57  2002.02.14  
Отображение главной формы


3-42707           Diver                 2002-01-18 12:37  2002.02.14  
блокировка таблиц Paradox